Najważniejsze funkcje matematyczne Excel i statystyczne Excel

Opublikowane przez admin w dniu

1. Jak korzystać z formuł matematycznych w Excel?

W tym rozdziale poznasz najważniejsze formuły matematyczne używane w Excelu. Z funkcji tych korzystamy w sposób standardowy wprowadzając jako argumenty funkcji liczby, adresy komórek lub też zakresu komórek. Szczegółowy sposób korzystania z najważniejszych formuł Excel opisywany jest w poprzednim rozdziale: Jak korzystać z formuł w Excel.

2. Jak obliczyć sumę, średnią, medianę, minimum i maksimum w Excel?

Do prostych obliczeń statystycznych Excel oferuje nam następujące funkcje:

SUMA – Funkcja zwraca sumę liczb wprowadzonych jako argumenty funkcji. Jako argument możemy wprowadzić zarówno liczby wprowadzone po średnikach jak i zakres liczb. Dla przykładu:

  • Jeśli chcielibyśmy obliczyć sumę z liczb z komórek A1, A2 i A5 powinniśmy posłużyć się następującym wzorem: =SUMA(A1;A2;A5). Argumenty funkcji oddzielone są średnikami.
  • Jeśli chcielibyśmy obliczyć sumę z liczb dla zakresu od A1 do A10 powinniśmy posłużyć się następującym wzorem: =SUMA(A1:A10). Argumenty funkcji wprowadzone są jako zakres od do z użyciem dwukropka.
  • Jeśli chcielibyśmy obliczyć sumę liczb z komórek A1, A2 i A5 i  jednocześnie dla zakresu od B1 do B10 powinniśmy posłużyć się następującym wzorem: =SUMA(A1;A2;A5;B1:B10). Argumenty funkcji wprowadzone są jako zakres od do z użyciem dwukropka. Argumenty oddzielamy od siebie średnikami.
Kurs Excel podstawy - Formuły Matematyczne - Excel Suma

Kurs Excel podstawy – Formuły Matematyczne – Excel Suma

ŚREDNIA – Funkcja zwraca średnią arytmetyczną z wprowadzonych wartości. W argumenty możemy wprowadzić zarówno liczby wprowadzone po średnikach jak i zakres liczb.

  • Jeśli chcielibyśmy obliczyć średnią z liczb z komórek A1, A2 i A5 powinniśmy posłużyć się następującym wzorem: =ŚREDNIA(A1;A2;A5). Argumenty funkcji oddzielone są średnikami.
  • Jeśli chcielibyśmy obliczyć średnią z liczb dla zakresu od A1 do A10 powinniśmy posłużyć się następującym wzorem: =ŚREDNIA(A1:A10). Argumenty funkcji wprowadzone są jako zakres od do z użyciem dwukropka.
  • Jeśli chcielibyśmy obliczyć średnią liczb z komórek A1, A2 i A5 i  jednocześnie dla zakresu od B1 do B10 powinniśmy posłużyć się następującym wzorem: =ŚREDNIA(A1;A2;A5;B1:B10). Argumenty funkcji wprowadzone są jako zakres od do z użyciem dwukropka. Argumenty oddzielamy od siebie średnikami.
Kurs Excel podstawy - Funkcje Matematyczne - Excel Średnia

Kurs Excel podstawy – Funkcje Matematyczne – Excel Średnia

MEDIANA – Funkcja zwraca medianę z wartości wprowadzonych jako argumenty. Argumentami funkcji mogą by zarówno liczby wprowadzone po średnikach jak i zakres liczb. Mediana to wartość środkowa. Oznacza to dla nas tyle, że 50% wartości w zbiorze ma wartość niższą od wartości mediany, a drugie 50% wartości w zbiorze ma wartość wyższą od wartości mediany.

  • Jeśli chcielibyśmy obliczyć medianę z liczb z komórek A1, A2 i A5 powinniśmy posłużyć się następującym wzorem: =MEDIANA(A1;A2;A5). Argumenty funkcji oddzielone są średnikami.
  • Jeśli chcielibyśmy obliczyć medianę z liczb dla zakresu od A1 do A10 powinniśmy posłużyć się następującym wzorem: =MEDIANA(A1:A10). Argumenty funkcji wprowadzone są jako zakres od do z użyciem dwukropka.
  • Jeśli chcielibyśmy obliczyć medianę liczb z komórek A1, A2 i A5 i  jednocześnie dla zakresu od B1 do B10 powinniśmy posłużyć się następującym wzorem: =MEDIANA(A1;A2;A5;B1:B10). Argumenty funkcji wprowadzone są jako zakres od do z użyciem dwukropka. Argumenty oddzielamy od siebie średnikami.
Kurs Excel podstawy - Funkcje Matematyczne - Excel Mediana

Kurs Excel podstawy – Funkcje Matematyczne – Excel Mediana

MIN – Formuła zwraca najmniejszą wartość z listy wartości, a więc tzw. minimum. Argumentami funkcji mogą by zarówno liczby wprowadzone po średnikach jak i zakres liczb.

  • Jeśli chcielibyśmy obliczyć minimum z liczb z komórek A1, A2 i A5 powinniśmy posłużyć się następującym wzorem: =MIN(A1;A2;A5). Argumenty funkcji oddzielone są średnikami.
  • Jeśli chcielibyśmy obliczyć minimum z liczb dla zakresu od A1 do A10 powinniśmy posłużyć się następującym wzorem: =MIN(A1:A10). Argumenty funkcji wprowadzone są jako zakres od do z użyciem dwukropka.
  • Jeśli chcielibyśmy obliczyć minimum liczb z komórek A1, A2 i A5 i  jednocześnie dla zakresu od B1 do B10 powinniśmy posłużyć się następującym wzorem: =MIN(A1;A2;A5;B1:B10). Argumenty funkcji wprowadzone są jako zakres od do z użyciem dwukropka. Argumenty oddzielamy od siebie średnikami.
Kurs Excel podstawy - Funkcje Matematyczne - Excel Minimum

Kurs Excel podstawy – Funkcje Matematyczne – Excel Minimum

MAX – Formuła zwraca największą wartość z listy wartości, a więc tzw. maksimum. Argumentami funkcji mogą by zarówno liczby wprowadzone po średnikach jak i zakres liczb.

  • Jeśli chcielibyśmy obliczyć maksimum z liczb z komórek A1, A2 i A5 powinniśmy posłużyć się następującym wzorem: =MAX(A1;A2;A5). Argumenty funkcji oddzielone są średnikami.
  • Jeśli chcielibyśmy obliczyć maksimum z liczb dla zakresu od A1 do A10 powinniśmy posłużyć się następującym wzorem: =MAX(A1:A10). Argumenty funkcji wprowadzone są jako zakres od do z użyciem dwukropka.
  • Jeśli chcielibyśmy obliczyć maksimum liczb z komórek A1, A2 i A5 i  jednocześnie dla zakresu od B1 do B10 powinniśmy posłużyć się następującym wzorem: =MAX(A1;A2;A5;B1:B10). Argumenty funkcji wprowadzone są jako zakres od do z użyciem dwukropka. Argumenty oddzielamy od siebie średnikami.
Kurs Excel podstawy - Funkcje Matematyczne - Excel Maksimum

Kurs Excel podstawy – Funkcje Matematyczne – Excel Maksimum

Wszystkie powyższe formuły możemy sprawdzić w tym pliku Excel z przykładem:

kurs_excel_podstawy_formuly_matematyczne_statystyczne.xlsx

3. Inne ważne funkcje liczbowe Excel.

ILE.LICZB – Funkcja zwraca liczbę wartości z wybranego zakresu komórek, które zawierają dane liczbowe.Dla przykładu jeśli mamy dane w zakresie od A1 do A20, wzór będzie wyglądał następująco: =ILE.LICZB(A1:A20). Tak jak w przypadku powyższych funkcji możemy tworzyć wzór na liczbach, komórkach, zakresach, a także wszystkich powyższych jednocześnie.

ILE.NIEPUSTYCH – Funkcja zwraca liczbę wartości z wybranego zakresu komórek, które zawierają jakiekolwiek dane. Dla przykładu jeśli mamy dane w zakresie od A1 do A20, wzór będzie wyglądał następująco: =ILE.NIEPUSTYCH(A1:A20). Tak jak w przypadku powyższych funkcji możemy tworzyć wzór na wpisanych ręcznie wartościach, komórkach, zakresach, a także wszystkich powyższych jednocześnie.

LOS – Zwraca liczbę losową z przedziału od 0 do 1. Jeśli chcielibyśmy wylosować w Excelu liczbę z zakresu np od 0 do 100, powinniśmy ją pomnożyć przez 100 i zaokrąglić. Funkcja LOS() nie wymaga wprowadzania argumentów. Dla przykładu =LOS().

MOD – Funkcja zwraca resztę z dzielenia jednej liczby przez drugą. Jako pierwszy argument wprowadzamy dzielą, a jako drugi argument dzielnik. Resztę z dzielenia liczby 100 na 3 otrzymamy za pomocą wzoru =MOD(100;3).

MODUŁ.LICZBY – Funkcja zwraca wartość bezwzględną z liczby. Zamienia wszystkie liczby ujemne na dodatnie. Dodatnie pozostawia bez zmian. Dla przykładu jeśli chcemy uzyskać wartość bezwzględną z liczby -110, korzystamy z wzoru =MODUŁ.LICZBY(-110).

PIERWIASTEK – Funkcja zwraca pierwiastek kwadratowy z argumentu. Dla przykładu pierwiastek kwadratowy z liczby 100 otrzymamy za pomocą wzoru =PIERWIASTEK(100).

POTĘGA – Funkcja podnosi liczbę do określonej potęgi. Potęgowanie możemy także wykonywać za pomocą operatora arytmetycznego „^” i ten sposób jest bardziej zalecany. Jeśli chcemy skorzystać z formuły powinniśmy jako pierwszy argument wprowadzić liczbę podnoszoną do potęgi, a jako drugi argument wykładnik potęgi. Np jeśli podnosimy liczbę 3 do potęgi drugiej zapiszemy to w następujący sposób: =POTĘGA(3;2).

RZYMSKIE – Funkcja zamienia liczby zapisane w formacie liczbowym na liczby rzymskie w postaci tekstu. Np =RZYMSKIE(20).

ZAOKR – Funkcja zaokrągla liczbę do określonej liczby miejsc po przecinku. Jako pierwszy argument wprowadzamy liczbę, którą chcemy zaokrąglić. Jak drugi argument liczbę miejsc po przecinku. Jeśli chcielibyśmy zaokrąglić liczbę 23,34534 do dwóch miejsc po przecinku zapiszemy to w następujący sposób: =ZAOKR(23,34534;2).

ZNAK.LICZBY – Funkcja zwraca znak liczby w postaci liczby -1 dla liczb ujemnych, 0 dla zera oraz 1 dla liczb dodatnich. Dla przykładu znak liczby -123 otrzymamy z działania =ZNAK.LICZBY(-123).

Kurs Excel podstawy - Funkcje matematyczne Excel i statystyczne

Kurs Excel podstawy – Funkcje matematyczne Excel i statystyczne

Podobne przykłady podstaw Excela zamieszczam w dziale kurs excel podstawy. Jeśli masz pytania co do tego rozdziału, możesz zamieścić je na forum bez logowania. Poniżej plik Excela z załączonym przykładem.

kurs_excel_podstawy_formuly_matematyczne_statystyczne.xlsx


Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

%d bloggers like this:
Inline
Inline